Package

purescript-unsafe-reference

Repository
purescript-contrib/purescript-unsafe-reference
License
MIT
Uploaded by
thomashoneyman
Published on
2021-02-26

CI Release Pursuit Maintainer: garyb Maintainer: thomashoneyman

Highly unsafe functions for comparing values using the runtime's strict (===) equality.

Installation

Install unsafe-reference with Spago:

spago install unsafe-reference

Quick start

The quick start hasn't been written yet (contributions are welcome!). The quick start covers a common, minimal use case for the library, whereas longer examples and tutorials are kept in the docs directory.

Documentation

unsafe-reference documentation is stored in a few places:

  1. Module documentation is published on Pursuit.
  2. Written documentation is kept in the docs directory.
  3. Usage examples can be found in the test suite.

If you get stuck, there are several ways to get help:

Contributing

You can contribute to unsafe-reference in several ways:

  1. If you encounter a problem or have a question, please open an issue. We'll do our best to work with you to resolve or answer it.

  2. If you would like to contribute code, tests, or documentation, please read the contributor guide. It's a short, helpful introduction to contributing to this library, including development instructions.

  3. If you have written a library, tutorial, guide, or other resource based on this package, please share it on the PureScript Discourse! Writing libraries and learning resources are a great way to help this library succeed.

Modules
Unsafe.Reference
Dependencies